Stellar Photometry

IDL photometry routines
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Stellar photometry

User guides for IDL photometry
routines:

ATV Aperture photometry
XStarFinder PSF-fitter /

deconvolver for

photometry in
crowded fields

M15, LRGB, from Mees
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https://www.physics.uci.edu/~barth/atv/instructions.html
http://www.bo.astro.it/StarFinder/paper6.htm

For calibration stars and uncrowded fields

If stars in an image are not very close together, most of us will
measure the stellar fluxes or magnitudes using aperture
photometry.

1. Add the DNs from each pixel within

» An aperture centered on the star, with an aperture radius
large enough to contain all of the stellar flux

» An annulus centered on the star that contains nothing but
background emission.

2. Multiply the annulus DNs by the ratio of number of
pixels in the aperture and annulus, and subtract this from
the aperture DNs.

> Note that this automatically happens in ATV.

Wite resuits tofie..
Hide r2d profle
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For calibration stars and uncrowded fields

> If the target is a calibration star, this is one measurement
of the flux density—to—DN conversion ratio, C, as
discussed in Lesson 4:

. F B Fol0—™ /2.5
DN, aperture — DN, sky DN aperture — DN, sky

C

where m is the star’s magnitude in the filter that is in use,
and F is the zero-magnitude flux density in that filter,
corrected for atmospheric extinction (Lesson 2).

» If not, its magnitude in that filter is

Fo
=251
m 8 <C<DNaperture - DNSky))
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Typical aperture photometry tool: ATV

B 00 - Cpregram Files Exelis IDLE ik g le-1-2-3gby padsagespraceduresiabi_belpar pro - 101 - o b
File Edit Source Project Run Window Help
; ; = H [ DIC ®
- | +* 4] | / . » @ @ > SMAINS .
ATV is a widely-used IDL . e . it -
: : : R Project.. &1 | B Outine | M- Variables| = 01 |[B8 tohist_definepro | B cubeviewspee_def.. | B tvawitcher_defin.. | B gbv_helperpro &2 | ™ CI=
application for browsing - :
B4 iDL Console i [ Command Histary [ Problems| 4" Search =8

000\ OreDrive - Universty o - ter\Dcuments\Classes\Mees\ OMW 01-14-2015 |l Cn |

images and performing e

IDL Version £.2, Microsoft Windows (Wind2 xS€_e4 med). (o7 Toe=

Installation number: 1373-1.

aperture photometry. Here is a S S i, o voneeees soveon
basic step-by-step guide: (g i

c module: AIV.
% Compiled module: XREGISTERED.

1. Start IDL N r——

v Compiled module: CW,

% Compiled module
s compilea moaule:

2. Browse to the directory | Comptted moaite:

% Compiled module

3 : % Compiled module GDEFAULTCOLCR .
containing the data. | Coiias moenie: cocercotomstart.
T h % Compiled module: ASINH.
3. Type atv <enter> at the | Compites mae
4 Compiled module

IDL> prompt. \ optied o

s Compiled mod

% Compiled module

% Compiled module: CGPLOTS.

4. This will produce the main .
ATV window (on right).
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Typical aperture photometry tool: ATV (it s o oGy o I

Min= 972160

Max=49602.3

5. File > ReadFits to open image

» This image should already be calibrated and
normalized.

6. FullView button to see the entire image.

7. Rotate/Zoom > Invert Y to make it right side
up, if it is a Mees image.

8. Mouse Mode > ImExam to start photometry mode.

9. Click a star. This brings up the atv aperture
photometry window.
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Typical aperture photometry tool: ATV

10. Click Show radial profile to see the entire window.

11. Adjust the settings:

» Aperture radius, inner, and outer sky radius so
that the aperture contains the stellar flux and the
annulus is unlikely to contain other stars.

> <Enter> after changing each parameter.

12. Photometry settings... button brings up a
dialogue by that name, with parameters to set.
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Cursor position: x= 994 y= 2610

Centering box size 1plx 40

Outer sky radius\3>.0000, ‘

'aming: Possible mis-centering?

Photometry settings
Write results to file.

Hide radial profile

FWHM (pi): 11.5
Sky level 116.572

[Magnitude: 12.9075

Uncertainty: 0.00120383

Done
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Typical aperture photometry tool: ATV

13. Choose your favorite among the counts (DN) and
magnitudes. I normally choose counts.

14. If you want magnitudes, set the Magnitude Zeropoint
according to the DN/exposure time for zero magnitude
(from your flux calibration) and the formula in this
window.

15. If you want photometric errors displayed, enter

» the CCD gain (1.35 ¢~ /DN; see Lesson 1)
» the system’s read noise (9 e~ for 1 x 1 binning, 4.5 ¢~ for
2 x 2 binning; see Lesson 1)

16. It is very easy to underestimate noise. You will ordinarily
deserve to get 0.05 mag, or as small as 0.01 mag with great
effort.

February 27,2024 (UR)

-

-

] atv photometry settings x

(®) IDLPhot Sky Mode
Select Sky Algorithm: () Median Sky

() No Sky Subiraction

(®) Counts

Select Output Units:
(O Magnitudes

Magnitude Zeropoint: |21.18901 A’

[ Magnitude = -2 5log (DN # exptime) = ZPT ]
ONe
(®) Yes

CCD Gain (e-/DN) [1.35000 |

Readout Noise (e-):

WARNING: Photometric emrors only make sense if the
gain and readnoise are given comectly
accounting for scaling or co-adding of images.

Cancel

Calculate photometric emors?
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Typical aperture photometry tool: ATV

17. If you want the counts or magnitudes of several
stars in the image, click Write results to file
in the atv aperture photometry window.

18. Then click on all of those stars in the image.
Click on the Close photometry file button
when you are finished.

X y r insky outsky sky mag err fwhm
989.9 2616.9 20.0 25.0 35.0 116.801 12.9054 0.00120174 11.84
856.7 2347.8 20.0 25.0 35.0 123.923 12.0863 0.000832432 11.42
1397.1 1689.7 20.0 25.0 35.0 124.359 12.8910 0.00117970 11.57
1532.1 1670.8  20.0 25.0 35.0 125.657  12.9645 0.00128254 13.97
22649 27782 200 25.0 35.0 216.200  9.98286  0.000395364 13.70
28537  3491.0  20.0 25.0 35.0 136.661 113016  0.000613421 11.92
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Other aperture photometry programs

This process can be automated using routines in or descended from the Goddard Space
Flight Center Astronomy Library:

» astrolib, for IDL
» photoutils within astropy or astroconda, for python

All of these are based on DAOPHOT, a well-tested set of routines written and maintained by
Peter Stetson, and often used with IRAF.

It is dangerous to automate this process, though, especially without some experience on
your images with aperture photometry by hand using the likes of ATV.
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https://idlastro.gsfc.nasa.gov/contents.html
https://photutils.readthedocs.io/en/stable/index.html
https://ui.adsabs.harvard.edu/abs/1987PASP...99..191S/abstract
https://www.uvic.ca/research/centres/arc/people/adjunct-members/stetson-peter.php

For crowded fields

If there are many stars in the image, if they

are crowded in parts, and if the stellar -
images are well sampled, automated PSF
photometry is best.

» Supply or calculate a PSF for the image.

» Find all of the stars in the image above
some threshold.

> Iteratively remove all of the stars by
CLEAN-like PSF subtraction. Record
centroids and total DNs for each star.

» Check the DNs on isolated stars with
aperture photometry.

M 15, on a not-so-great night in October 2016

February 27,2024 (UR) 11/22



Typical PSF photometry tool: XStarFinder

XStarFinder is an IDL routine for PSF fitting _
and photometry in crowded fields of both o
the diffraction-limited (AO) and the
seeing-limited sort. To use it,

1. Start IDL (if you have not yet done so)

2. Browse to the directory containing the
data

3. Type xstarfinder <enter> at the IDL>
prompt.

4. This produces the main XStarFinder
window.

5. Push the Image button to load a
calibrated image.

M 15, on a not-so-great night in October 2016
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https://www.oas.inaf.it/en/research/m5-en/starfinder-en/

Typical PSF photometry tool: XStarFinder

6. Under Display > Options,
adjust the scale and stretch of
your image so that you can see
all of your stars.

» The image will be mirror
inverted (North down), as in
ATV. Unfortunately, there is
no Invert Y function this
time.

7. Under Image > Noise >
Compute, choose Evaluate
from data and click the
Compute button.

B XDisplayOpt X

Minimum intensity| 70.0000 >
Maximum intensity

Stretch:
() square

Olinear

O square root

| |reverse scale

Chopping threshold | 1.00000e+006

Color Table:

B-WLINEAR A
BLUEMWHITE

GRN-RED-BLU-WHT

RED TEMPERATURE
BLUE/GREEN/RED/YELLOW ¥

Apply options

Help | Exit

B XNoise

Gi ian noise:

Evaluate from data: (_)no

Read-out-noise (electrans) 0.000000
Dark current (electrons) 0.000000
Thermal background (electrons) 0.000000

Sky (ADU) 0.000000

Phaton noise:

Consider photon noise (@no () yes
General par

Number of exposures 1

Exposures combined by (®) mean sum

Electrons/ADU 1.00000

Help || Exit
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Typical PSF photometry tool: XStarFinder

8. Click OK on the next window to

10.

bring up the XNoise_StDev
window. Accept the defaults
and click Processing. . .

An information window
appears with the grand-total
noise result. Click 0K, Exit,
Exit to get out of the
noise-calculation process.

Define the point spread
function (PSF) to use to
deconvolve the image. Choose
PSF > Extract from image to
get the XPsf_Extract window.

&) XMoise_5De

Pre-processing:

Patch size for median subtraction|3

Fraction of data point to use|1.00000

Histogram computation:

Threshold to reject out-liers (St. Dev. units) 3

Size of histogram (FWHM unlts)

Minimum number of bins in one HWHM |5

Histogram fitting:

(®) gaussian

() gaussian + costant

() gaussian + linear

() gaussian + quadratic

Processing... ) Plot histogram

Mode =

0.0129582

Standard deviation =
1.91208
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Typical PSF photometry tool: XStarFinder

11. Set output PSF to be about 25;
otherwise, accept the default '
settings.

12. Click Processing. . ., then OK
on the next window.

13. Left-click on 5-10 relatively o
bright, isolated stars.
Right-click when you are
finished.

14. You will then be asked to
confirm (Yes) or reject (No)
your choices. Reject any that
do not look like the others, e.g.
are not round.
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Typical PSF photometry tool: XStarFinder

o

15. You should have no secondary
sources nearby, so say No in the
next window.

16. 0K when done.

17. Non-rejected stellar profiles are ‘ i

==
averaged to produce the PSF. =ED
Choose Display PSF to see
what you got.

18. Exit. You will be asked if you
want to save the PSF stars. Do
so if you have more images
aligned with this one to
process. (PSF > Load to get
them back.)
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Typical PSF photometry tool: XStarFinder

19. You should now be back on the st i
. . . Search

main XStarFinder window. S i

Choose Astrometry and P ——

Photometry to bring up the Corsion

XStarFinder_Run window. orson skl 203

. . No. of sub-puxel D"SE‘E’?—‘
» This is the part that does the PSF 1ossa Information X
fitting and subtraction. Bl so s stimato
. Upgrade background

20. Accept the defaults and click boce rbckpmund st R sfd | 0 9333 detected stars.

PI'OCGSSiIlg e [T Estimate background by median fitering

. . . Fitling and deblending
21. This will likely take a few (2—4) T ——
) L. ) oK
mlnutes; 1t Wlll iterate aCCOfdlng to Minimum distance of closa sourcas (FWHM units) 1.00000 -
the number in the Final [t st s
. . . . [] Devlend rejected sources

refitting iterations box. R
22. When finished, you will get an Filny s

information box that says how :‘"‘; &=

p

many stars were found.
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Typical PSF photometry tool: XStarFinder

23. Reduce Detection threshold
and/or Correlation threshold if
you think that you deserve to find =
more stars.

.....

24. Save results or you will have to
do the last step over again; then
Exit to return to the XStarFinder
window.

25. Display > Select data >
Detected sources shows what it
says (example shown on the right).

» Note that there will often be

regions so crowded that point
sources cannot be extracted.
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Typical PSF photometry tool: XStarFinder

©

26. Once you have extracted the stars
from all of your images, choose =
Compare lists.

27. You can then load two lists (Files)
and Match coordinates between
them. Accept the default values
provided in the XMatch Coord
window that pops up.

» This is easiest if you have already
aligned the images as carefully as
you can.

» Also load a “Reference list” (can
be your PSF stars file).
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Typical PSF photometry tool: XStarFinder

28. To acquire the subset of the two
lists that appear in both, click the
Find coincident button in the
XMatch Coord window. Enter the
width of the PSF (or your best
estimate of it) in the Matching
distance window that pops up.

29. Save the subset of each file that
appears in both lists: File > Save
for each list.
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Typical PSF photometry tool: XStarFinder

M15 §.:
30. With our filters, it is best to plot the H-R | 5744 stars ey

diagrams as G v. B-R, so you will need “ Wk

to identify the stars in common in all

three images. 15
» You can do this by using Match )
coordinates cyclically between the +
three. :

31. Almost done. Convert the DNs in your
list to fluxes, using your flux calibration 18

in each filter. ] R,

» Or, better yet, convert them to )

magnitudes, assuming that you have
observed a star cluster and want to

plot its H-R diagram. 21

20

-025 000 025 050 075 100 125 150 175 200
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Other PSF-photometry programs

DAOPHOT is really a hybrid of star search, aperture photometry, PSF fitting, and
precision photometry.
» All work under IDL or python.
» When compared to XStarFinder, the only downside is that there is no
GUL
Source Extractor (a.k.a. SExtractor) can pull stars out from moderately crowded fields or
(better) from within bright nebulosity.
» This is not what SExtractor was designed for, though. The precision of
the photometry is better in DAOPHOT and XStarFinder.
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https://www.astromatic.net/software/sextractor

